Habe heute mein MikTex aktualisiert und bei dem Update von KOMA-Script 3.16 auf 3.17a kommt es bei meinen Projekten beim Kompilieren zu folgender Fehlermeldung:

Open in Online-Editor
! Undefined control sequence.
<argument> ...akspace }\thechapter \autodot \IfUsePrefixLine 
                                                  {}{\enskip }
l.12   \chapter{Test}

Hier ein Minimalbeispiel, das den o.g. Fehler bei Verwendung von KOMA-Script 3.17a hervorruft:

Open in Online-Editor
\documentclass{scrreprt}

\makeatletter
\renewcommand\chapter{\@startsection
   {chapter}{1}{0mm}%            % name, ebene, einzug
   {\baselineskip}%              % vor-abstand
   {0.5\baselineskip}%           % nach-abstand
   {\bfseries\sffamily\Large}%   % layout
   }
\makeatother

\begin{document}
  \chapter{Test}
\end{document}

Bei KOMA-Script 3.16 tritt der Fehler nicht auf.

gefragt 08 Jun '15, 10:12

dzaic's gravatar image

dzaic
721829
Akzeptiert: 85%

bearbeitet 09 Jun '15, 13:15

saputello's gravatar image

saputello
18.4k22352

Hallo dzaic,

ich hatte das gleiche Problem unter Texlive 2015 Petest und habe meine Dateien radikal verändert, frag mich nicht, was ich alles raus genommen habe. Langer Rede kurzer Sinn, schau dir mal dies an: http://tex.stackexchange.com/questions/246411/koma-script-how-to-style-the-title-of-a-chapter

Gruß

Martin

(08 Jun '15, 10:49) nixversteh
2

Sieht so aus, als würde \chapterformat außerhalb von \@@makechapterhead ausgeführt (wobei ich nicht verstehe, warum es so definiert wurde, dass das nicht geht ...).

(08 Jun '15, 12:15) Ulrike Fischer
1

Bitte erstelle ein Minimalbeispiel. Ulrike hat Dir ja schon den Tipp gegeben, dass es mit Deiner Formatierung der Kapitelüberschriften zu tun haben dürfte.

(09 Jun '15, 05:07) esdd
1

Warum nimmst du nicht das dokumentierte Interface um das Aussehen der Kapitel zu ändern? \RedeclareSectionCommand[optionen]{chapter}

(09 Jun '15, 08:47) Johannes

Bei der aktuellen Beta von KOMA-Script 3.18 funktioniert übrigens sogar Dein Code, obwohl er sicher nicht im Sinne des Erfinders ist.

(09 Jun '15, 13:17) saputello

Wenn ein neues Kapitel nicht stets eine neue Seite beginnen soll, dann musst Du bei Verwendung von \RedeclareSectionCommand zur Umdefinition der Überschriftenebene chapter zusätzlich style=section verwenden. Die von Dir erwähnte Fehlermeldung kannst Du beseitigen, in dem Du \chapterformat so definierst, wie bei Dir die Kapitelnummer in der Überschrift ausgegeben werden soll.

Open in Online-Editor
\documentclass{scrreprt}[2015/02/07]
\usepackage{blindtext}

\RedeclareSectionCommand[
style=section,
beforeskip=1\baselineskip,
afterskip=.5\baselineskip,
font=\Large
]{chapter}
\renewcommand*{\chapterformat}{%
  \mbox{\chapappifchapterprefix{\nobreakspace}\thechapter%
  \autodot\enskip}}

\begin{document}
\KOMAScriptVersion
\chapter{Kapitel Eins}
\blindtext
\chapter{Kapitel Zwei}
\blindtext
\end{document}

Ob der erste Absatz nach der Überschrift mit Absatzeinzug (wie in Deiner Frage) oder ohne Absatzeinzug (wie in Deiner Antwort) gesetzt wird, hängt vom Vorzeichen von beforeskip ab. Ein negatives Vorzeichen entspricht dem Standardverhalten, d.h. dann wird der erste Absatz nach der Überschrift nicht eingezogen.

alt text


Mit der nächsten KOMA-Script Hauptversion nach der 3.17a wird die Neudefinition von \chapterformat nicht mehr nötig sein.

Permanenter link

beantwortet 09 Jun '15, 10:57

esdd's gravatar image

esdd
14.2k53251

bearbeitet 09 Jun '15, 13:18

Vielleicht sollten wir bei dem neuen Zeug ein bestimmte Mindestversion über das optionale Argument der Klasse anfordern. Dann gibt es zumindest eine Warnung, wenn man über den Online-kompiler geht.

(09 Jun '15, 11:03) Johannes

@esdd Herzlichen Dank für deine kompetente Antwort. Ich habe Sie als Lösungsvorschlag markiert, da ich denke, dass Du alle Aspekte meiner Frage berücksichtigst, während ich lediglich dafür "gesorgt" habe, keine Fehlermeldung zu bekommen.

(09 Jun '15, 11:04) dzaic
1

@Johannes Gewohnheit ;-) Aber ich habe es jetzt geändert und als Mindestversion die 3.16 angefordert. Vermutlich funktioniert das auch schon mit der 3.15, aber das kann ich jetzt nicht auf die Schnelle testen.

(09 Jun '15, 11:13) esdd

@esdd Wenn ich beforeskip=1\baselineskip, weglasse, bekomme ich einen missing number-Fehler. Ist der auch in der nächsten Version behoben?

(10 Jun '15, 03:16) Ulrike Fischer

@Ulrike Ja, wenn ich die Beta-Version verwende, gibt es im Gegensatz zur 3.17a keinen Fehler.

(10 Jun '15, 03:24) esdd

Mit den Hinweisen der Helfer, denen ich recht herzlich für ihre Unterstützung danken möchte, ergibt sich für koma-script grösser 3.17a folgende Vorgehensweise, die nicht zu der von mir geschilderten Fehlermeldung führt:

Open in Online-Editor
\documentclass{scrreprt}
\usepackage{blindtext}

\RedeclareSectionCommand[%
  beforeskip=-10pt plus -2pt minus -1pt,%
  afterskip=0.5\baselineskip plus -1sp minus 1sp,
  font=\bfseries\sffamily\Large%
]{chapter}

\begin{document}
  \Blinddocument
\end{document}
Permanenter link

beantwortet 09 Jun '15, 10:16

dzaic's gravatar image

dzaic
721829

Ich bekomme da Warnungen not defining \chapter due to not yet defined section style. Der Code tut auch nicht das gleiche: Mit deinem alten Code führte \chapter kein \newpage mehr aus, hier aber schon. Abgesehen davon zeigt m.E. dein ursprünglicher Fehler einen Bug, es fehlt eine Defaultdefinition von \IfUsePrefixLine , und du solltest den melden.

(09 Jun '15, 10:37) Ulrike Fischer
1

@Ulrike Der erste Teil sollte mit den ersten Anmerkungen in http://komascript.de/release3.17 erklärt sein.

(09 Jun '15, 10:41) Johannes

@Ulrike Bei mir läuft es einwandfrei durch, und zwar sowohl mit latex, pfdlatex wie auch lualatex. Und mit dem "newpage" hast Du recht, das ist mir noch gar nicht aufgefallen. Ändere ich aber beforeskip=-10pt plus -2pt minus -1pt zu beforeskip=\baselineskip, so wie es auch in meinem Ursprungsbeitrag ist, dann kommt die Fehlermeldung: unknown option 'beforeskip=\baselineskip'

Ich verstehe nur noch Bahnhof. :-)

(09 Jun '15, 10:43) dzaic

@Ulrike Mit der Entwicklerversion gibt es auch die Fehlermeldung wegen nicht definierten \IfUsePrefixLine nicht mehr. Insofern ist da keine Meldung mehr nötig.

(09 Jun '15, 10:45) esdd
(09 Jun '15, 10:53) Johannes
1

@dzaic Eine Erklärung, warum beforeskip=\baselineskip nicht erkannt wird, findest Du zum Beispiel hier.

(09 Jun '15, 14:45) esdd
Ergebnis 5 von 6 Alle anzeigen
Deine Antwort auf die Frage (nicht auf andere Antworten)
Knebel-Vorschau

Folge dieser Frage

Per E-Mail:

Wenn Du Dich anmeldest, kannst Du Updates hier abonnieren

Per RSS:

Antworten

Antworten und Kommentare

Aktuelle Buch-Infos

LaTeX Cookbook

LaTeX Beginners Guide

Limitierter Rabatt ebook
50% Coupon code tDRet6Y

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs füge einfach zwei Leerzeichen an die Stelle ein, an der die neue Zeile sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Zugeordnete Themen:

×83
×73
×33
×5

Frage gestellt: 08 Jun '15, 10:12

Frage wurde angeschaut: 4,240 Mal

Zuletzt aktualisiert: 10 Jun '15, 03:24