Hey,

vielleicht könnt ihr mir ja helfen. Ich habe ein Miktex-Update getätigt und damit relativ viele Pakete aktualisiert, unter anderem LuaLaTex auf Version 0.95. hyperref liegt in Version 6.83m vor. Kann mir jemand sagen, wieso meine Links nicht mehr anklickbar sind?

Beim Kompilieren beschwerte sich LaTex über die Option pdfTex beim Paket hyperref. Diese Angabe scheint veraltet zu sein und daher habe ich sie entfernt. Das Dokument war danach kompilierbar, aber es gehen eben keine Links: weder im Inhaltsverzeichnis, noch manuell gesetzte oder Links im Glossar.

Ebenso sind die Meta-Angaben im PDF-Dokument verschwunden nach dem Update. Die Felder Titel und Autor sind leer.

Minimalbeispiel:

Open in Online-Editor
\documentclass[a4paper, 12pt,oneside]{scrartcl}
\usepackage{polyglossia}
\setmainlanguage[spelling=new]{german}
\usepackage[hidelinks,unicode,pdfencoding=unicode,
            colorlinks=true,
            allcolors={red},
            pdfauthor={x},
            pdftitle={x}]{hyperref}
\usepackage[headsepline,footsepline]{scrpage2}
\usepackage{fontspec}
\usepackage[parfill]{parskip}
\usepackage{lmodern}
\usepackage{microtype}
\usepackage{newunicodechar}
\usepackage{amsmath}
\newunicodechar{}{-\nolinebreak\hspace{0pt}}
\makeglossaries
\begin{document}
\title{x}
\subtitle{x}
\author{x}
\maketitle
\clearpage
    {
        \hypersetup{linkcolor=black}
        \tableofcontents
    }
    \section{Section 1}
    \printglossary
\end{document}

gefragt 12 Mai, 03:24

Mountainic's gravatar image

Mountainic
265
Akzeptiert: 100%

geschlossen 17 Mai, 04:37

saputello's gravatar image

saputello
18.4k22352

1

Bin am Handy unterwegs, daher kein Test on meinerseite, Aber bis auf wenige Ausnahmen gehört hyperref als letztes geladen, Vielleicht hängt das irgendwie daran.

(12 Mai, 04:01) NobbZ
1

Scheint ein Fehler zu sein, der nach dem Update auftritt, laut Johannes' Link sind die Entwickler informiert. Ist ja auch ein wesentliches Thema. Btw. pdftex als Option sollte sowieso nicht mit LuaLaTeX funktionieren, also gut, dass es raus ist.

(12 Mai, 04:05) stefan ♦♦

Dann hoffe ich mal, dass das die Tage behoben ist. Ich gebe dann hier eine Rückmeldung, ob meine beiden Fehler verschwunden sind, nach einem erneuten Update.

(12 Mai, 04:09) Mountainic
1

Die korrekte hyperref-Version wäre 6.83n vom 5/5/2016. Wenn sie beim nächsten miktex-Update nicht kommt, solltest du das bei miktex melden.

(12 Mai, 04:52) Ulrike Fischer

Die Frage wurde aus folgenden Grund geschlossen: "Das Problem ist veraltet und löst sich durch ein Update von hyperref (min. 6.83n) selbst." durch saputello 17 Mai, 04:37


Nach einem Update auf hyperref-Version 6.83n funktioniert bei mir wieder alles. Das Problem ist also gelöst.

Permanenter link

beantwortet 17 Mai, 03:37

Mountainic's gravatar image

Mountainic
265

Folge dieser Frage

Per E-Mail:

Wenn Du Dich anmeldest, kannst Du Updates hier abonnieren

Per RSS:

Antworten

Antworten und Kommentare

Aktuelle Buch-Infos

LaTeX Cookbook

LaTeX Beginners Guide

Limitierter Rabatt ebook
50% Coupon code tDRet6Y

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs füge einfach zwei Leerzeichen an die Stelle ein, an der die neue Zeile sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Zugeordnete Themen:

×41
×13

Frage gestellt: 12 Mai, 03:24

Frage wurde angeschaut: 632 Mal

Zuletzt aktualisiert: 17 Mai, 04:37