Ich benutzt MikeTex 2.9 in Verbindung mit Texniccenter und möchte PDF's erstellen.

Die Vorgeschichte:

Ich habe bereits ein größeres Dokument mit Hilfe einer Vorlage erzeugt. Hat alles wunderbar funktioniert. Nun wollte ich mir ein Dokumente selber zusammenbauen bauen. Hat auch alles wunderbar funktioniert bis ich an die Problematik mit dem zitieren kam. Biber hat aus irgendeinem Grund die Arbeit verweigert. Irgendwelche Dateien wurden nicht gefunden obwhl sie da waren woe sie gesucht wurden. Ich habe Miktex und Texniccenter neu installiert in der Hoffnung das es Hilft.

% Edit nach dem ersten Kommentar%

Also mein Vorgehen beim planlosen deinstallieren und neu installieren sah so aus:

1.) Ich hab alles was in irgendeiner Beziehung Latex stand deinstalliert.
2.) Hab nur Miktex installiert und in dem mitgelieferten Editor(Texworks) ein Minibeispiel geschrieben und erfolgreich eine pdf erzeugt.
3.) pdflatex.exe direkt gestartet und versucht aus der in Schritt (2) erstellte TEX-Datei erneut in eine pdf zu erzeugen. Kriegt dan in der Konsole ne Fehlermeldung bezügliche fehlender.aux Datei.
4.) Nur zum Test habe ich dann jeweils Texniccenter bzw. TexStudio installiert und versucht die Datei aus (2) auszuführen. Texniccenter sagt "0 fehler 0 warnungen 0 seiten" und TexStudio meckert auch wegen der .aux rum.

Beide Editoren aus (4) erzeugen keinerlei andere Dateien. Also auch keine Logdatei die bei der Fehlersuche helfen könnte. Konfiguriert sind beide korrekt, da beide Editoren mit identischen Einstellungen schonmal funktioniert haben. die Geschichte mit Biber spielt jetzt momentan keine Rolle, da ich erstmal wieder eine grundlegende Funktion herstellen will.

Sachen die ich zusätzlich schon Ausprobiert habe.

  • Gründliche Reinigung der Registry nach der Deinstallation
  • Bereinigung der Festplatte von Temporären und Config-Dateien
  • nutzen der "ausführen als Administratorfunktion"
  • Installation der portable Versionen auf nem Usb-Stick

Fehlermeldung von pdflatex.exe

alt text

Der Code der Tex Datei :

Open in writeLaTeX
\documentclass{article}
\begin{document} 
 Hello world!
\end{document}

% Aktualisierung 22.9.14 22uhr

Also hab jetzt noch ein bisschen rum getestet. Wenn ich die portable Installation von Miktex nutzte funkitoniert jetzt alles wieder tiptop. Also Prompt, eingebauter Editor und fremde Editoren funktionieren. Wenn ich aber die normal Installation von Miketex nutz, verweigern mir die Editoren wieder die Arbeit. Hab auch nochmal Texlive als Alternative getestet. Promt und eingebauter Editor geht auch dort. Wenn ich aber fremde Editoren nehme passiert wieder nichts.

Ich vermute also dass irgendwas in meinem System die Funktionalität der regulären Installation behindert. Gibs ne Möglichkeit das zu beheben oder sollte ich bei Zeiten mein System neu aufsetzen?

gefragt 22 Sep '14, 09:59

Anapha's gravatar image

Anapha
112
Akzeptiert: 0%

geschlossen 19 Nov, 07:25

saputello's gravatar image

saputello
18.4k22352

1

Es kann viele Gründe geben, warum "es nicht mehr funktioniert". Deine Beschreibung ist viel zu vage und durcheinander, um zu wissen, was bei dir nicht geht: Ein Fehlerbeschreibung mit mindestens zwei Installation, drei Editoren und dazu noch biber kann niemand aus der Ferne debuggen. Hör aber auf planlos alles mögliche zu Deinstallieren und neu zu installieren und von einem Editor zum anderen zu hoppeln. Fang mit einem Minidokument an und löse deine Problem nacheinander und systematisch.

(22 Sep '14, 10:15) Ulrike Fischer

@Anapha Willkommen auf der TeXwelt! Lies mal die erzeugte .log-Datei, dort sollten Informationen über die Fehlerursache stehen. Ggf. poste Ausschnitte hier. Dafür kannst Du Deine Frage jederzeit editieren (keine Antwort posten, denn Antworten sind hier echte Antworten auf die Frage). Weitere Infos gern als Kommentare, und wie gesagt Frage-Editieren. Erzähle mal Details (Fehler, Log) einer kleinen Test-Datei samt Code.

(22 Sep '14, 10:25) stefan ♦♦

Selbst wenn in dem Ordner die korrekte .aux Datei ist, meckert er rum. Den genauen Wortlaut des Fehlers schreib ich gleich in die Frage.

(22 Sep '14, 10:59) Anapha
1

Bei Schritt 3 hast du einen Fehler. Halte dort an. Beschreibe alles was zu diesem Fehler führte genau, zeige screenshots, den Inhalt der Datei usw.

(22 Sep '14, 11:01) Ulrike Fischer
1

Seufz. Wieso muss man immer nachfragen? Gründlichkeit geht hier vor Schnelligkeit. Beschreibe alles, was zu diesem Fehler führte, genau, zeige screenshots, den Inhalt der Datei usw. Code kannst du hier eingeben, indem du ihn mit 4 Leerzeichen einrückst (markdown syntax).

(22 Sep '14, 11:17) Ulrike Fischer
1

Zeige wie du pdflatex konkret aufrufst. Ganz besondere den Prompt, d.h. den Ordner indem du dich befindest.

(22 Sep '14, 11:23) Ulrike Fischer

@Ijon Tichy: Ich weiß genau, wie ich den Fehler (miktex spezifisch) selbst produzieren kann. Ich weiß nur noch nicht, ob Anapha das auch so hingekriegt hat ;-).

(22 Sep '14, 11:44) Ulrike Fischer

@Ijon Tichy: Ich weiß, dass der Kommentar mir nicht galt. Aber deine Hypothese, dass "etwas grundlegendes falsch ist ... mit den Rechten" könnte dazu führen, dass Anapha die Spur verlässt und dem nächsten Irrlicht nachläuft. Erstmal Daten sammeln ist besser.

(22 Sep '14, 12:06) Ulrike Fischer

Kurze Aktualisierung : pdflatex funktioniert jetzt wieder im Prompt. Bin mir nicht sicher woran es lag, hab den Rechner nur von der Arbeit nach Hause mitgenommen und jetzt geht's aus irgend einem Grund. Einzige Änderung war jetzt der Neustart. Hab ich aber auch schon zuvor öfters getestet. Ich werde noch testen ob der Editor auch wieder funktioniert und nochmal Rückmeldung geben.

(22 Sep '14, 13:34) Anapha
3

Ich habe noch nie bei irgendeinem TeX-Problem mein System oder mein TeX-System neu installiert. Ich habe jedes Problem anders gelöst. Aber das funktioniert nur, wenn man sich nicht wie ein "mongoose" verhält, um mal die Nomenclature aus diesem sehr lesenswerten Artikel zu verwenden: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. Hektisches Rumtesten hilft nicht ein Problem zu verstehen. Und wenn du Hilfe von anderen willst, dann darfst du nicht dauernd dein System ändern, sonst fängt jede Untersuchung wieder bei Null an.

(23 Sep '14, 03:56) Ulrike Fischer

Für diejenige, die sich wundern, dass der Link nicht funktioniert: Da ist irrtümlich der Punkt vom Satzzeichen mit in den Link gerutscht. Korrekt lautet er http://www.chiark.greenend.org.uk/~sgtatham/bugs.html oder auf Deutsch http://www.chiark.greenend.org.uk/~sgtatham/bugs-de.html.

(05 Nov, 15:05) saputello
Ergebnis 5 von 11 Alle anzeigen

Die Frage wurde aus folgenden Grund geschlossen: "Das Problem ist nicht reproduzierbar oder veraltet" durch saputello 19 Nov, 07:25

Folge dieser Frage

Per E-Mail:

Wenn Du Dich anmeldest, kannst Du Updates hier abonnieren

Per RSS:

Antworten

Antworten und Kommentare

Aktuelle Buch-Infos

LaTeX Cookbook

LaTeX Beginners Guide

Limitierter Rabatt ebook
50% Coupon code tDRet6Y

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs füge einfach zwei Leerzeichen an die Stelle ein, an der die neue Zeile sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Zugeordnete Themen:

×13
×12

Frage gestellt: 22 Sep '14, 09:59

Frage wurde angeschaut: 4,678 Mal

Zuletzt aktualisiert: 19 Nov, 07:25