Hallo, ich möchte mit Biblatex arbeiten, jedoch sind die Versionen von meinem Biblatex (3.6) und biber (2.5) nicht miteinander kompatibel. Also öffne ich das Programm "Miktex update", wähle aus dass die Updates aus dem Internet geladen werden sollen und klicke auf weiter. Anschließend kommt folgende Fehlermeldung:

MiKTeX Problem Report Message: The package definition file could not be parsed. Data: path="C:\Users\Rosanna\AppData\Local\Temp\mik89974\makeindex.tpm", column="1330", line="2" Source: Libraries\MiKTeX\PackageManager\TpmParser.cpp Line: 330 MiKTeX: 2.9 OS: Windows 10 Education, 64-bit, build 14393 Invokers: non-existing/explorer SystemAdmin: no PowerUser: no Root0: C:\Users\Rosanna\AppData\Roaming\MiKTeX\2.9 Root1: C:\Users\Rosanna\AppData\Local\MiKTeX\2.9 Root2: C:\ProgramData\MiKTeX\2.9 Root3: C:\Program Files\MiKTeX 2.9 UserInstall: C:\Users\Rosanna\AppData\Roaming\MiKTeX\2.9 UserConfig: C:\Users\Rosanna\AppData\Roaming\MiKTeX\2.9 UserData: C:\Users\Rosanna\AppData\Local\MiKTeX\2.9 CommonInstall: C:\Program Files\MiKTeX 2.9 CommonConfig: C:\ProgramData\MiKTeX\2.9 CommonData: C:\ProgramData\MiKTeX\2.9

Was kann ich tun, damit Miktex update funktioniert? Über Tipps würde ich mich sehr freuen.

gefragt 05 Nov '16, 14:18

Annasor's gravatar image

Annasor
3115
Akzeptiert: 0%

geschlossen 06 Nov '16, 10:10

saputello's gravatar image

saputello
10.0k53459

1

Willkommen auf TeXwelt!

Bitte achte künftig bei Deinen Beiträgen auf korrekte Markdown-Syntax.

(05 Nov '16, 14:50) saputello
1

Möglicherweise gab es einen Fehler beim Download der angegebenen Datei. Wechsle ggf. das Repository. Außerdem sei darauf hingewiesen, dass es bei MiKTeX gerade eine kleine Umstrukturierung gibt (Link beachten!).

(05 Nov '16, 14:54) saputello
1

Außerdem sei darauf hingewiesen, dass Du nicht nur MiKTeX Update sondern auch MiKTeX Update (Admin) ein Update durchführen lassen solltest. biber ist nämlich häufig über den Admin-Paketmanager installiert, während biblatex häufig über den Benutzer-Paketmanager installiert ist. Mit dem Admin-Updatemanager kann man aber nicht die Benutzerpakete updaten und umgekehrt. Das gilt erst recht für die Umstrukturierung, so dass man ggf. Pakete auch über den jeweiligen Paketmanager deinstallieren und die neuen Pakete installieren muss.

(05 Nov '16, 14:54) saputello

Danke für die schnelle Antwort! Ich habe das Repository mehrmals gewechselt, sowohl bei dem Benutzer-Updatemanager als auch bei dem Admin-Updatemanager. Die Fehlermeldung bleibt die gleiche.

Inzwischen habe ich Miktex deinstalliert, nochmal runtergeladen und wieder neuinstalliert. Müssten jetzt nicht alle Pakete aktuell sein?

Die Versionen von biblatex 3.6 und biber 2.5 sind aber immer noch nicht miteinander kompatibel und die miktex updater (admin- und benutzer-) geben auch die selbe Fehlermeldung aus.

(05 Nov '16, 18:08) Annasor
1

Versuch es morgen noch mal.

(06 Nov '16, 02:26) Johannes

Inzwischen habe ich Miktex deinstalliert, nochmal runtergeladen und wieder neuinstalliert. Müssten jetzt nicht alle Pakete aktuell sein?

Dazu steht auf der Download-Seite von MiKTeX:

When you have installed MiKTeX, it is recommended that you run the update wizard in order to get the latest updates.

(06 Nov '16, 03:06) saputello
1

Siehe auch MiKTeX Portable update failure.

Es kann außerdem notwendig sein (und schadet normalerweise auch nicht), im Paketmanager (erst in der Admin-Version, danach auch noch in der User-Version) über das Menü eine Synchronisation des Repositories durchzuführen.

(06 Nov '16, 03:50) saputello

Danke! Nachdem ich erst den Paketmanager(admin) und dann den Paketmanager synchronisiert habe, hat es funktioniert!

(06 Nov '16, 09:17) Annasor
Ergebnis 5 von 8 Alle anzeigen

Die Frage wurde aus folgenden Grund geschlossen: "Das Problem ist veraltet und kann durch Update aus einem synchronisierten Repository behoben werden." durch saputello 06 Nov '16, 10:10

Folge dieser Frage

Per E-Mail:

Wenn Du Dich anmeldest, kannst Du Updates hier abonnieren

Per RSS:

Antworten

Antworten und Kommentare

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs füge einfach zwei Leerzeichen an die Stelle ein, an der die neue Zeile sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Zugeordnete Themen:

×22

Frage gestellt: 05 Nov '16, 14:18

Frage wurde angeschaut: 1,560 Mal

Zuletzt aktualisiert: 06 Nov '16, 10:10