TeXwelt wurde neu installiert. Es funktionieren noch nicht alle Features und auch an den deutschsprachigen Formulierungen wird verbessert. Danke für eure Geduld.

Ich habe ein Problem bei der Verwendung von dot2texi in Kombination mit dem Minted-package (geladen von tcolorbox). Unter Linux/MacOS habe ich keine Probleme mit dem Dokument, aber aus Gründen auf die ich keinen Einfluss habe muss Windows 10 herhalten. Python, Pygments, Graphviz, dot2tex sind installiert und zum Systempfad hinzugefügt.

Folgendes Minimalbeispiel:

\documentclass{article}

\usepackage{dot2texi}

\usepackage{tikz}
\usetikzlibrary{shapes,arrows}
\begin{document}

\begin{dot2tex}[neato,mathmode]
digraph G {
node [shape="circle"];
a_1 -> a_2 -> a_3 -> a_4 -> a_1;
}
\end{dot2tex}

\end{document}

Kompiliert mit shell-escape erhalte ich ein PDF mit dem entsprechenden Graphen.

\documentclass{article}

\usepackage[many,minted]{tcolorbox}

\begin{document}

\begin{tcblisting}{colback=red!5!white,colframe=red!75!black}
This is a \LaTeX\ example which displays the text as source code
and in compiled form.
\end{tcblisting}
\end{document}

In diesem Fall wird das PDF auch problemlos kompiliert, die Einfärbung des Befehls funktioniert ohne Probleme (was für mich heißt, dass Pygments installiert ist und gefunden wird).

Um gleichzeitig dot2texi und Minted nutzen zu können, habe ich zunächst diese Antwort adaptiert, damit es kein Problem mit dem listing-Befehl gibt. Als gemeinsames Dokument habe ich dann:

\documentclass{article}

\usepackage[many,minted]{tcolorbox}

\let\mlisting\listing
\let\endmlisting\endlisting
\let\listing\relax
\expandafter\let\csname mlisting*\expandafter\endcsname\csname
listing*\endcsname
\expandafter\let\csname endmlisting*\expandafter\endcsname\csname
endlisting*\endcsname
\expandafter\let\csname listing*\endcsname\relax

\usepackage{dot2texi}

\usepackage{tikz}
\usetikzlibrary{shapes,arrows}
\begin{document}

\begin{tcblisting}{colback=red!5!white,colframe=red!75!black}
This is a \LaTeX\ example which displays the text as source code
and in compiled form.
\end{tcblisting}

\begin{dot2tex}[neato,mathmode]
digraph G {
node [shape="circle"];
a_1 -> a_2 -> a_3 -> a_4 -> a_1;
}
\end{dot2tex}

\end{document}

Wenn ich nun das kompilieren lasse, wird mir plötzlich gemeldet:

! Package minted Error: You must have `pygmentize' installed to use this package. See the minted package documentation for explanation.

Weiß jemand, wieso jetzt ein Problem mit Minted/Pygments auftritt bzw. wie man das beheben kann?

Nachtrag: bisher ist es mir nicht aufgefallen, weil es immer zu schnell durchgelaufen ist, aber ich erhalte als weitere Meldung bevor der obige Fehler angezeigt wird:

Der Befehl "rm" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Der Befehl "which" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Der Befehl "dot2tex" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

system returned with code 1 system returned with code 1 system returned with code 1

Ich habe bei den funktionierenden Versionen jetzt auch mal darauf geachtet. Für das erste Dokument (wo dot2texi funktioniert) erhalte ich:

Der Befehl "rm" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

system returned with code 1

Für die Version wo Minted funktioniert erhalte ich:

system returned with code 1

gefragt 06 Aug, 12:42

Hirshy's gravatar image

Hirshy
6461639
Akzeptiert-Rate: 0%

bearbeitet 06 Aug, 13:05


dot2texi nutzt Code um windows zu erkennen. Dieser Code wurde irgendwann mal aus ifplatform kopiert und dann nicht angepasst und in einem aktuellen windows scheitert er wegen falscher Anführungszeichen und setzt \ifwindows auf falsch. Das bringt minted (das mit aktuellen ifplatform windows richtig erkannt hat) aus dem Tritt.

Du kannst versuchen hinter dem Paket den Switch zu korrigieren:

\usepackage{dot2texi}
\windowstrue

Aber da ich dot2tex nicht installiert habe, kann ich nicht testen, ob es irgendwo scheitert.

Permanenter link

beantwortet 06 Aug, 17:07

Ulrike%20Fischer's gravatar image

Ulrike Fischer
3.3k23
Akzeptiert-Rate: 53%

Mit der händischen Korrektur läuft es jetzt durch, gibt nur noch die Meldung bezüglich "rm" was falsch geschrieben/nicht gefunden werden kann aus. Damit kann ich aber für den Moment leben, danke!

(06 Aug, 20:25) Hirshy
Deine Antwort
Vorschau umschalten

Folgen dieser Frage

Per E-Mail:

Wenn sie sich anmelden, kommen Sie für alle Updates hier in Frage

Per RSS:

Antworten

Antworten und Kommentare

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs fügen Sie einfach zwei Leerzeichen an die Stelle an der die neue Linie sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Frage-Themen:

×8
×1

gestellte Frage: 06 Aug, 12:42

Frage wurde gesehen: 632 Mal

zuletzt geändert: 06 Aug, 20:25