TeXwelt wurde neu installiert. Es funktionieren noch nicht alle Features und auch an den deutschsprachigen Formulierungen wird verbessert. Danke für eure Geduld.

Ich habe ein Diagramm erstellt und wollte die Fläche unterhalb der Graphen mit unterschiedlichen Farben schraffieren. In der Vorschau von meinem Texmaker ist die Schraffur auch richtig dargestellt, nur wenn ich die pdf-Datei separat öffne, fehlt die rote Schraffur. Warum ist das so?

Öffne in Overleaf
\documentclass[a4paper]{scrartcl}
\usepackage{amssymb,amsmath}
\usepackage{graphicx} 
\usepackage{amsfonts}
\usepackage{verbatim}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}         % Umlaute wie ä,ö,ü, etc. können direkt eingegeben werden
\usepackage{ulem}
\usepackage{color}
\usepackage{geometry}
\usepackage{scrlayer-scrpage}
\usepackage{siunitx}
\usepackage{lastpage}
\usepackage{tikz}
\usetikzlibrary{arrows,intersections,patterns}
\begin{document}
\begin{tikzpicture}[
    thick,
    >=stealth',
    dot/.style = {
      draw,
      fill = white,
      circle,
      inner sep = 0pt,
      minimum size = 4pt
    }
  ]
  \coordinate (O) at (0,0);
  \draw[->,thick] (-0.3,0) -- (6,0) coordinate[label = {below:$t$}] (tmax);%x-Achse
  \draw[->,thick] (0,-0.3) -- (0,4.5) coordinate[label = {left:$v(t)$}] (vmax);%y-Achse
  \draw[pattern=north east lines, pattern color=red!20] (0,0)--(0,4)--(1,4)--(1,0) ;
  \draw[-,color=red] (0,4)--(1,4)--(1,0);
  \draw[pattern=north west lines, pattern color=blue!20] (0,0.75)--(5,0.75)--(5,0)--(0,0);
  \draw[-,color=blue] (0,0.75)--(5,0.75)--(5,0);
  \draw[-,thin] (1.5,0)--(1.5,0.75);
  \draw[-,thin] (4.5,0)--(4.5,0.75); 
  \path (1,0) node[dot, label = {below:$t_{L}$}]{};
  \path (1.5,0) node[dot, label = {below:$t_{1}$}]{};
  \path (5,0) node[dot, label = {below:$t_{S}$}]{};
  \path (5.5,0) node[dot, label = {below:$t_{2}$}]{};
  \path (0,4) node[dot, label = {left:$v_{L}$}]{};
  \path (0,0.75) node[dot, label = {left:$v_{S}$}]{};
 \end{tikzpicture}
\end{document}

gefragt 12 Apr '18, 13:02

Volker's gravatar image

Volker
414
Akzeptiert-Rate: 0%

bearbeitet 12 Apr '18, 13:30

1

Ich kann das Problem nicht nachvollziehen, sowohl die Vorschau von Overleaf als auch mehrere PDF-Viewer (z. B. Okular und Evince) zeigen die Schraffur bei mir an:

alt text

Vielleicht liegt es an Deinem PDF-Viewer. Welchen verwendest Du? Probier einen anderen. Bekannt für Darstellungsprobleme ist beispielsweise der PDF-Viewer von OS X.

(12 Apr '18, 13:28) saputello

Hi Saputello, das ist aber interessant. Ich benutze den Acrobat-Reader. Danke für die Info!

(12 Apr '18, 13:32) Volker

Ich habe Deine "Antwort" in einen Kommentar umgewandelt. Du kannst gern stets direkt die Frage editieren und Zusätze einfügen. Hier sind Antworten stets "echte" Antworten, keine Gespräche oder Rückfragen oder Zusatzinfos, sondern Lösungen. Editieren der Frage ist jederzeit möglich und erwünscht. Das verbessert die Übersicht erheblich für die Archivierung der Lösungen. Ungewohnt und anders als in Webforen, doch innovativ und nutzbarer. Bemerkungen gern wie hier als Kommentare.

Darüber hinaus solltest Du @saputello verwenden, wenn Du mich direkt ansprechen willst. Vgl. andere Kommentare.

(12 Apr '18, 13:35) saputello

Den Acrobat Reader gibt es übrigens nicht. Jede Version verhält sich anders. Teilweise unterscheiden sich auch die (scheinbar) gleichen Versionen unter unterschiedlichen Betriebssystemen. Und dann kann man auch noch selbst Einstellungen ändern.

(12 Apr '18, 13:37) saputello

Ich kann die Schraffur auch im Acrobat Reader DC (Version 2018.011.20038) sehen.

(12 Apr '18, 13:37) esdd

@esdd: ich habe auch die Version 2018.011.20038 Welche Einstellungen hast Du denn bei Dir?

(12 Apr '18, 13:43) Volker
Ergebnis 5 von 6 show 1 more comments
Das erste sein, diese Frage zu beantworten!
Vorschau umschalten

Folgen dieser Frage

Per E-Mail:

Wenn sie sich anmelden, kommen Sie für alle Updates hier in Frage

Per RSS:

Antworten

Antworten und Kommentare

Markdown-Grundlagen

  • *kursiv* oder _kursiv_
  • **Fett** oder __Fett__
  • Link:[Text](http://url.com/ "Titel")
  • Bild?![alt Text](/path/img.jpg "Titel")
  • nummerierte Liste: 1. Foo 2. Bar
  • zum Hinzufügen ein Zeilenumbruchs fügen Sie einfach zwei Leerzeichen an die Stelle an der die neue Linie sein soll.
  • grundlegende HTML-Tags werden ebenfalls unterstützt

Frage-Themen:

×671
×40
×11
×2

gestellte Frage: 12 Apr '18, 13:02

Frage wurde gesehen: 1,050 Mal

zuletzt geändert: 12 Apr '18, 13:43